Редактор формул

OpenOfficeOpenOffice.org (OOo) имеет компонент для создания и редактирования математических формул. Обычно он используется как редактор формул в текстовых документах, но может также использоваться с другими типами документов или автономно.

1Когда используется внутри Writer, уравнение обрабатывается как объект в текстовом документе.

Редактор формул предназначен для того, чтобы писать формулы в символической форме. Если Вы хотите вычислить числовое значение, смотри руководство по электронным таблицам

Задания

Начало

Чтобы вставить формулу в «OpenOffice.org Редактор текстов» (далее OOo Writer), выполните Вставить > Объект > Формула Math. Внизу экрана открывается Редактор формул, и появляется всплывающее окно Элементы формулы. Вы будете также видеть маленький блок (с серой границей) в вашем документе, где будет отображаться формула.

Рис. 1.

Рис. 1. Редактор формул, окно Выбор, и местоположение формулы


Редактор формул использует язык разметки для представления формул. Например, %beta создает греческий символ Бета.

Эта разметка разработана, чтобы читать подобно английскому языку всякий раз, когда это возможно. Например, a over b отображается как дробь:

Дробь

Ввод формулы

Есть три способа ввести формулу:

  • Выбрать символ из окна Выбор.
  • Щелкнуть правой кнопкой мыши на редакторе формулы и выбрать символ из появившегося контекстного меню.
  • Ввести разметку в редакторе формул.

Контекстное меню и окно Элементы формулы вставляют разметку, соответствующую символу. Кстати, это обеспечивает удобный способ изучить разметку Ooo Math.

Нажмите по области документа, чтобы выйти из редактора формул.
Дважды щелкните на формуле, чтобы снова войти в редактор формул

Окно Выбор

Самый простой метод для ввода формулы - окно Элементы формулы:

Символы, разделенные на категории

Окно Элементы формулы разделено на две главные части:

  • Верхняя показывает категориям символов. Нажмите по ним, чтобы изменить список символов.
  • Нижняя показывает символы, доступные в текущей категории.
Вы можете скрыть (или открыть) окно Элементы формулы при помощи Вид > Элементы формулы

Пример 1

5х4 Введем эту простую формулу.

В окне Элементы формулы:

  • Выберем верхнюю левую кнопку в секции категорий (сверху).
  • Нажмем по символу умножения.

Унарные / Бинарные операторы

Когда Вы выбираете символ умножения на окне Элементы формулы, происходят две вещи:

  • редактор уравнения показывает разметку: Умножение
  • в области документа появляется серый блок с рисунком: Блок

Символ умножения

Символы <?> вы должны заменить соответствующим текстом. После чего формула автоматически обновится, и результат должен быть таким:

Результат ввода «5» и «4» рядом с оператором «times»

Чтобы препятствовать формуле автоматически обновляться, выберите Вид > Автообновление экрана. Чтобы обновлять формулу вручную, нажмите F9, или выберите Вид > Обновить.

Контекстное меню

Другой способ обратиться к математическим символам состоит в том, чтобы щелкнуть правой кнопкой мыши на редакторе формулы. Это вызовет меню:

Контекстное меню

Пункты в этом меню в точности соответствуют пунктам в окне Элементы формулы.

Язык разметки

Вы можете ввести команды языка разметки непосредственно в редакторе формулы. Например, Вы можете ввести «5 times 4». Если Вы знаете язык разметки, это может быть самым быстрым способом ввести формулу.

Мнемонически, язык разметки формул напоминает чтения формулы по-английски.

Ниже приведен краткий список общих формул и соответствующие им конструкции языка разметки.

Краткий список

Греческие символы

Греческие символыГреческие символы обычны в математических формулах. Эти символы не доступны в блоке выбора или через контекстное меню. К счастью, через язык разметки ввести греческие символы просто: напечатайте признак % и следом за ним название символа, по-английски.

  • Чтобы напечатать символ нижнего регистра, напишите имя символа в нижнем регистре.
  • Чтобы напечатать символ верхнего регистра, напишите имя символа в верхнем регистре.

Другой способ вводить греческие символы - использовать окно каталога. Идите в Сервис > Каталог.

Каталог - используется для того, чтобы вводить греческие символы

В списке «Набор символов» выберите «Греческий» и двойным щелчком на нужном греческом символе в списке.

Пример 2

π

Для этого примера мы предположим что:

  • Мы хотим ввести вышеупомянутую формулу (значение пи, округленное до 5 десятичных знаков);
  • Мы знаем имя греческого символа («pi»);
  • Мы не знаем конструкцию языка разметки, связанную с символом Символ.

Инструкция:

  • Шаг 1: Введите %, сопровождаемый текстом «pi». Появится греческий символ π.
  • Шаг 2: Откройте окно Элементы формулы (Вид > Элементы формулы).
  • Шаг 3: Cимвол Символ это отношение, так что мы нажимаем по кнопке Отношения Отношение. Если вы наведете курсор мыши на эту кнопку, вы увидите всплывающую подсказку «Отношения»:

Всплывающая подсказка указывает кнопку «Отношения»

  • Шаг 4: Удалите текст и добавьте «3.14159» в конец формулы. Следовательно мы закончили конструкцией «%pi simeq 3.14159».

Конечный результат

Настройки

Редактор формул как плавающее окно

Редактор формулы может занимать большую часть окна Writer'а. Чтобы превратить редактор формул в плавающее окно, сделайте следующее:

  • Наведите курсор мыши на рамку редактора.

Удерживая Клавишу Control сделайте двойной щелчок на границе математического редактора, чтобы превратить его в плавающее окно

  • Нажмите клавишу Control и выполните двойной щелчок.

Редактор формул как плавающее окно

Вы можете превратить плавающее окно обратно во внедренную рамку, используя те же самые шаги. Удерживайте клавишу Control, и дважды щелкните по оконной рамке.

Размер формулы

Это один из самых обычных вопросов людей, спрашивающих об OOo Math. Ответ является простым, но не интуитивно понятным:

  • Запустите редактора формул и выберите Формат > Кегли…

Изменение размера шрифта формулы

  • Выберите больший размер шрифта в поле «Осн. размер» (самое верхнее поле)

Размер шрифта

  • Результат этого изменения:

Результат изменения базового размера шрифта

Планировка формулы

Самые большие трудности при использования OOo Math вызывает написание сложных формул. Этот раздел дает некоторые представления о написании сложных формул.

Скобки - ваши друзья

OOo Math не знает ничего о порядке операции. Вы должны использовать скобки для явного задания порядка обработки операторов. Рассмотрим следующий пример:

Пример

Формула больше чем из одной строки

Предположим, что Вы хотите напечатать формулу, состоящую более чем из одной строки.

Формула

Ваша первая реакция состояла бы в том, чтобы просто нажать Клавишу Enter. Однако, если вы нажимаете клавишу Enter, хотя разметка переходит на новую строку, окончательная формула этого не делает. Вы должны явно ввести команду newline.

Таблица

Область общих проблем

Как мне добавить пределы сумме/интегралу?

Команды «sum» и «int» могут иметь параметры «from» и «to». Они используются для задания нижнего и верхнего пределов соответственно. Эти параметры могут использоваться отдельно или вместе.

Таблица

Скобки для матриц выглядят уродливыми!

Чтобы понять предпосылку проблемы, мы кратко рассмотрим матричные команды:

Таблица

Строки матрицы разделяются двумя символами ##, а элементы в пределах каждой строки одним символом #.

Первая проблема с которой сталкиваются пользователи, имеющие дело с матрицами - то, что скобки «не масштабируются» с матрицей:

Таблица

OOoMath предоставляет «масштабируемые» скобки. То есть скобки, которые растут в размере, чтобы соответствовать размеру их содержимого. Используйте команды left( и right) чтобы ввести масштабируемые скобки.

Таблица

Используйте left[ и right] для получения квадратных скобок.

Различные типы Скобок

Почти во всех формулах требуются различные типы скобок. Формулы в OpenOffice позволяют использовать нескольких видов скобок.

  • { } структурные фигурные скобки: используются для группирования частей формулы и определения порядка обработки операторов.
  • ( ) Круглые скобки: используются для группирования частей формулы. Круглые скобки отображается в конечной формуле.
  • [ ] квадратные скобки: используются так же, как круглые скобки ().
  • { } фигурные скобки: поскольку символы {} используются для команд программы и не отображаются в конечной формуле, фигурные скобки должны вводится как lbrace для '{' и rbrace для '}'.
  • В случае если нужна одна скобка, например для написания системы уравнений, то вместо второй скобки пишем ключевое слово none.
  • Размер скобок может управляться с командами left и right.

Пример

Как мне сделать производную?

Создание производных по существу сводится к одной уловке: Скажите OOo, что это - дробь.

Другими словами, Вы должны использовать команду «over». Объедините ее с введенной буквой «d» (для полной производной) или командой «partial» (для частной производной), чтобы достигнуть эффекта производной.

Производные

Внимание, вы должны использовать фигурные скобки, чтобы ввести производную

Нумерация формул

Нумерация формул - одна из лучших скрытых особенностей OOoMath. Шаги просты, но не очевидны:

  • Откройте ООо Writer
  • Начните новую строку
  • Введите «fn» и затем нажмите F3

«fn» будет заменено пронумерованной формулой:

Формула 2 (2)

Теперь Вы можете дважды щелкнуть на формуле, чтобы ее отредактировать. Например, вот - функция Riemann Zeta:

Формула 3 (3)


Вы можете вставить ссылку на формулу в соответствии со следующими шагами:

  1. Вставить > Перекрестная ссылка
  2. Нажать по вкладке Ссылки.
  3. В поле Тип, выберите Текст.
  4. В поле Выбор, укажите номер формулы.
  5. В поле Формат, выберите Ссылка.
  6. Нажмите Вставка.

Если Вы позже добавите формулу в документ перед формулой, на которую ссылаетесь все формулы будут автоматически перенумерованы, и перекрестные ссылки обновлены.

Вставка перекрестной ссылки на номер формулы

Чтобы вставлять номер формулы без круглых скобок вокруг него, выберите Нумерация в поле Формат вместо Текст ссылки
ooo/math.txt · Последние изменения: 22/04/2016 00:04 — ybezrukov
CC Attribution-Noncommercial 4.0 International
Driven by DokuWiki Recent changes RSS feed Valid CSS Valid XHTML 1.0