Урок 2

Стили и указатели

… или как сделать красивый и правильный документ!

Задание

Скачайте файл к себе в домашнюю папку. Этот файл уже содержит набранный текст. Ваша задача изменить стиль документа, добавить оглавление, иллюстрации, алфавитный указатель, разбить текст на главы. Все эти действия делаются средствами пакета OOo Writer. Чтобы успешно справиться с заданием Вам необходимо ознакомиться с ПОЯСНЕНИЯМИ к заданию.

В результате выполнения задания у Вас получится замечательный документ. Вот что получилось у меня - Result.pdf

Сдать задание

Сдайте готовый и выверенный odt-файл!

Исправить работу МОЖНО, сдав ее еще раз, пока не отправите на окончательную проверку!

Пояснения

Разметка стилями и вставка оглавления

1) Отображение непечатаемых символов Включить отображение непечатаемых символов в документе и удалить лишние знаки абзаца там, где с их помощью начинается новая страница, и там, где с их помощью делаются отступы вокруг заголовков, т.е. удалить в документе все пустые абзацы.

2) Открыть панель «Стили» <F11>, выбрать внизу панели фильтр «Автоматически» и разметить заголовки в тексте с помощью стилей «Заголовок 1» и «Заголовок 2».

Стили

Стилем «Заголовок 1» размечаются самостоятельные заголовки (заголовки первого уровня), которые при нумерации, нумеровались бы одной цифрой (1.). Стилем «Заголовок 2» размечаются заголовки второго уровня (подзаголовки), которые при нумерации, нумеровались бы двумя цифрами (1.1.)

3) Удалить текущее оглавление вместе со словом «Оглавление». Вместо него вставить автоматически сформированное оглавление: «Вставка/ Оглавления и указатели/ Оглавления и указатели/ OK».

4) Переключить фильтр внизу панели «Стили» в положение «Используемые стили». Если Writer после этой операции завершил работу с ошибкой, то эту операцию НЕ делайте больше!!! В нашей текущей версии, это происходить не должно.

Редактирование формата стилей

5) На панели стилей щелкнуть по названию стиля «Заголовок1» правой кнопкой мыши и выбрать пункт «Изменить» Изменение форматирование стиля

6) Изменить стиль «Заголовок1» следующим образом:

  • В закладке «Эффекты шрифта - Эффекты» – выбрать «прописные»;
  • В закладке «На странице» – установить опцию «Добавить разрыв» (страница, перед);
  • В закладке «Отступы и интервалы» – установить интервалы: перед абзацем – 0см, интервал после абзаца – 1,2см;
  • На закладке «Выравнивание» выбрать «По центру».

7) Изменить стиль «Заголовок 2» по своему усмотрению, а также изменить стиль «Базовый».

8) В верхней части окна стилей переключить фильтр со стилей абзаца Стиль абзаца на стили символов Стиль символов и изменить стиль «Выделение» также по своему усмотрению.

9) Обновить оглавление, кликнув на поле оглавления правой кнопкой мыши, и выбрав пункт «Обновление указателя».

Настройка автонумерации заголовков

10) Настроить автоматическую нумерацию заголовков. Доступ к этом диалоговому окну можно получить через меню «Сервис/Структура нумерации»

11) Последовательно произвести соответствующие настройки нумерации для Уровень1 - Заголовок 1 — Номер… и Уровень 2 - Заголовок 2 — Номер…

Настройка структуры нумерации документа

12) Выключить нумерацию на абзацах заголовков «Введение» и «Выводы». Удалить номера, введенные ранее вручную, у всех других заголовков.

Третья пиктограмма слева - выключить нумерацию

НавигаторДля быстрого перемещения по структуре документа используйте Навигатор

13) Примерно посредине введения вставьте новый абзац с текстом «Пробный заголовок» и разметьте его как заголовок первого уровня.

14) Заново обновить оглавление.

Стили страницы, колонтитулы

Стиль страницы 15) Включить колонтитулы у документа. Для этого в верхней части окна стилей переключить фильтр на стили страницы и изменить текущий стиль (Обычный) следующим образом:

  • в закладке «Верхний колонтитул» включить опцию «Верхний колонтитул»;
  • в закладке «Нижний колонтитул» включить опцию «Нижний колонтитул».

16) Вставить в верхний колонтитул название текущей главы. Для этого:

  • установить курсор на странице в позицию верхнего колонтитула;
  • в меню «Вставка / Поля» выбрать «Дополнительно / закладка Документ / Глава / Название главы».

17) Пронумеровать страницы документа. Для этого:

  • установить курсор в нижний колонтитул и в меню «Вставка / Поля» выбрать «Номер страницы»;
  • следом приписать «из» и из того же меню выбрать «Количество страниц».
Как убрать номер первой страницы после того как вставили нумерацию страниц в документе.
  • Зайти в колонтитул, где есть нумерация страницы
  • Формат - Стили
  • В окошке «Стили и форматирование» четвёртая кнопка «Стили страницы»
  • «Первая страница» двойной клик.

Стиль абзаца 18) В верхней части окна стилей переключить фильтр на стили абзаца и поочередно изменить стили «Нижний колонтитул» и «Верхний колонтитул» таким образом, чтобы:

  • начертание шрифта в колонтитулах было курсивным;
  • кегль шрифта был меньшим по размеру, чем кегль стиля «Базовый»;
  • текст в колонтитулах имел обрамление (линия снизу для верхнего колонтитула и линия сверху для нижнего колонтитула).

19) Еще раз обновить оглавление, т. к. с появлением колонтитулов распределение текста по страницам могло измениться.

Гиперссылки в оглавлении

20) Чтобы сделать возможным быстрое перемещение к заголовкам документа посредством оглавления (<Ctrl> — клик) необходимо вставить гиперссылки в структуру его элементов. Для этого:

  1. Находясь курсором над полем «Оглавление» щелкнуть правой кнопкой мыши и выбрать «Правка указателя».
  2. В открывшемся диалоговом окне выбрать закладку «Элементы» — она следующая после закладки «Вид».
  3. Строка «Структура» представляет собой набор элементов - кнопок и белых полей:
    1. Кнопка Э# — номер заголовка;
    2. Кнопка Э — текст элемента;
    3. Кнопка Т — позиция (шаг) табуляции;
    4. Кнопка — номер страницы;
    5. Белые поля - пробелы.
  4. Для добавления гиперссылки:
    1. В строке «Структура», поместить курсор в белое поле слева от кнопки Э#;
    2. Нажать кнопку «Гиперссылка» — Кнопка ГН (начало гиперссылки) появится в строке «Структура»;
    3. Поместить курсор в белое поле справа от кнопки Э;
    4. Снова нажать кнопку «Гиперссылка» — Кнопка ГК (конец гиперссылки) появится в строке «Структура»;
    5. Нажать кнопку «Все уровни», чтобы гиперссылки появились во всех имеющихся уровнях оглавления.

Вставка гиперссылки в структуру элемента оглавления

По умолчанию Writer создает оглавление с гиперссылками со стилем символа Интернет—­ссылка. Т.е. оглавление получается с подчеркиванием. Если требуется оглавление без подчеркивания - можно сменить стиль символа на Ссылка указателя, или отредактировать стиль Интернет—ссылки, используются кнопку «Изменить»

Вставка иллюстраций

Картинки для вставки
Картинки для вставки Картинки для вставки Картинки для вставки

21) Вставить по тексту иллюстрации. Для этого нужно:

  • сохраните приведенные картинки на диск в свою домашнюю папку:
    • кликните правой кнопкой мыши по картинке и выберите «Открыть в новой вкладке»;
    • перейдите в новую вкладку и кликните левой кнопкой мыши по картинке еще раз;
    • кликните правой кнопкой мыши по картинке и выберите «Сохранить изображение как …»;
    • сохраните изображение.
  • установить курсор в то место документа, куда вы хотите вставить иллюстрацию;
  • вызвать меню: «Вставка / Изображение / Из файла»;
  • выбрать на диске графический файл и нажать кнопку «Открыть».
Обратите внимание, что когда изображение выделено, в меню «Стили» (откройте его, если оно закрыто! - F11) автоматически выбирается стиль «Изображение» во вкладке «Стили врезки»

22) Изменить стиль врезки «Изображение» по своему усмотрению.

Изучите закладки стиля врезки «Изображение» самостоятельно
Обратите внимание, что некоторые параметры изображения можно настроить только из контекстного меню, которое вызывается правой кнопкой, когда вставленное изображение выделено. В том числе пункт «Изображение…» контекстного меню, содержит больше вкладок, чем вы видели при редактировании одноименного стиля врезки

23) Когда изображение выделено, из контекстного меню изображения либо из меню Вставка выбрать пункт «Название» и вписать в соответствующее поле открывшегося диалога название для вашей иллюстрации.

24) Отредактировать стиль абзаца «Иллюстрация», которым оформляется название иллюстрации во врезке так, чтобы у него не было отступа красной строки, и размер шрифта был мельче, чем у стиля «Базовый». При желании отредактировать стиль врезки «Врезка», который появился среди используемых стилей после добавления названия изображения.

Вставка названия иллюстрации

25) Вставить в другие места текста оставшиеся две иллюстрации, также дав им названия.

Вставка указателя «Список иллюстраций»

26) После последнего абзаца документа вставить разрыв страницы (Вставка / Разрыв / Разрыв страницы) со стилем «Первая страница».

Вставка разрыва страницы с изменением стиля страницы

Мы меняем стиль страницы, чтобы сделать новую страницу без колонтитулов.

27) Установить курсор на вновь образованной странице и вызвать «Вставка / Оглавления и указатели / Оглавления и указатели».

28) В закладке «Вид» из одноименного списка выбрать «Список иллюстраций» и нажать ОК.

Вставка списка иллюстраций

Формирование алфавитного указателя

29) Выделить в тексте слово, которое вы хотите включить в алфавитный указатель, например, слово «Предприниматель».

30) Вызвать из меню: «Вставка / Оглавление и указатели / Элемент». В открывшемся диалоге установить настройки так:

Вставка элемента указателя

31) Выделить в тексте как элемент указателя так же слова «маркетинг» и «реклама». (Для поиска этих слов в документе используйте «Правка / Найти и заменить»).

32) Поставить курсор в конце последней страницы (после Списка иллюстраций) и вставить Алфавитный указатель. Для этого:

  • Вызвать из меню: «Вставка / Оглавление и указатели / Оглавление и указатели»;
  • На странице «Вид» из одноименного списка выбрать «Алфавитный указатель» и нажать «ОК».
  • Правой кнопкой мыши вызвать полученный указатель на редактирование и перенастроить его параметры. Оценить изменения.

Параметры алфавитного указателя

Сохранение и экспорт в .pdf

33) Сохранить текущую версию файла (формат .odt).

34) Сделать pdf-версию файла. Для этого выбрать в меню «Файл / Экспорт в PDF» и следовать инструкциям диалогового окна.

35) Просмотреть полученный PDF-файл.

ooo/writer/task4.txt · Последние изменения: 22/03/2018 12:57 — ybezrukov
CC Attribution-Noncommercial 4.0 International
Driven by DokuWiki Recent changes RSS feed Valid CSS Valid XHTML 1.0